Shepherd Application Service Disruption

Incident Report for Shepherd Veterinary Solutions

Resolved

Following the deployment of a fix, we maintained an extended monitoring period to validate performance and ensure service stability. Systems have continued to operate normally throughout this period, with no recurrence of the issue observed.

Based on this sustained stability, we are now marking this incident as Resolved. Thank you for your patience while we worked through remediation and validation.
Posted Sep 15, 2026 - 10:37 EDT

Update

Service performance has stabilized and is currently operating as expected. We are continuing to closely monitor the environment while implementing additional stabilizing measures as remediation efforts continue.
Posted Sep 14, 2026 - 12:28 EDT

Monitoring

Service performance has improved, though some users may continue to experience intermittent delays. We are closely monitoring the environment for stability and will provide additional updates as performance continues to normalize.
Posted Sep 14, 2026 - 12:17 EDT

Investigating

We have identified an issue causing significant service degradation and impacting normal operations. Our team is actively working to restore full service as quickly as possible.

We apologize for the disruption and will provide additional updates as remediation progresses.
Posted Sep 14, 2026 - 12:11 EDT
This incident affected: Shepherd Application, Shepherd Pay, SMS (Texting Services), AI Services (TranscribeAI, SummarizeAI, DiagnoseAI), OpenAPI (Clinic Connect and Integrations), and Shepherd Support Chat (Intercom).