Intermittent Slowness and Connectivity Issues

Incident Report for Shepherd Veterinary Solutions

Resolved

We identified and mitigated the underlying issue contributing to slowness. Service performance is now operating normally, and we will continue monitoring.
Posted Jan 05, 2026 - 12:15 EST

Monitoring

We’ve identified the cause of the slowness and have mitigation in place.
Some users may still experience residual slowness while performance fully stabilizes.
We’re continuing to monitor performance closely - thank you for your patience.
Posted Jan 05, 2026 - 11:50 EST

Investigating

We are currently investigating an issue with intermittent slowness and connectivity with Shepherd. If Shepherd becomes fully inaccessible, read-only access will be available.

https://ees.shepherd.vet/login

Learn more about read-only here -
https://help.shepherd.vet/en/articles/9142634-read-only-mode-and-emergency-kit
Posted Jan 05, 2026 - 11:43 EST
This incident affected: Shepherd Application, SMS (Texting Services), and OpenAPI (Clinic Connect and Integrations).