Cloudfare Global Network Performance Issues

Incident Report for Shepherd Veterinary Solutions

Resolved

Cloudflare has reported that their services are now operating normally.

Throughout the incident, our systems remained stable, but because Cloudflare an upstream provider for AI services and many external vendors, we closely monitored their recovery to ensure there were no downstream impacts.

At this time, all services are fully operational, and no further issues are expected. We will continue routine monitoring, but this incident is now considered resolved.
Posted Nov 18, 2025 - 12:45 EST

Update

Cloudflare continues to work through a network issue that is causing intermittent errors and increased latency across their services. While performance has improved, Cloudflare has not yet confirmed full resolution, and some sporadic impact may still occur.

Our systems remain stable, but because Cloudflare is one of our upstream providers, we are monitoring the situation closely for any potential downstream effects.

We will continue to track Cloudflare’s recovery efforts and will update this page as new information becomes available.
Posted Nov 18, 2025 - 11:38 EST

Update

A fix has been implemented by Cloudflare, and they believe the incident is now resolved. Their teams are continuing to monitor to ensure all network services fully recover.

Our systems have not experienced any impact during this event. However, because we know our users rely on multiple integrated vendors, we provide these updates to maintain transparency and help you understand any upstream issues that may have been in motion.

We will continue monitoring Cloudflare’s status and will update this page if anything changes.
Posted Nov 18, 2025 - 09:51 EST

Monitoring

An external operational issue with Cloudfare Global Network has been identified.
While the Shepherd application remains stable, several integrated vendor services or Shepherd AI features may impacted. Our team is actively monitoring the situation as Cloudfare works toward resolution.

For real-time Cloudfare service information, please refer to the Cloudfare Status Page (https://www.cloudflarestatus.com).
Posted Nov 18, 2025 - 07:00 EST
This incident affected: AI Services (TranscribeAI, EchoAI, DiagnoseAI).